Article 4
Done, sorry about that. I can't see a way to remove the old .txt file (not that familiar with trac).
View ArticleArticle 2
Replying to djcp: I suppose you could do something stupid like enter "*.com" and allow anyone with a .com address to register in your multisite install, but c'mon. You can't fix stupid. :-) I like...
View Articlekeywords changed
keywords has-patch added; needs-patch removed So if a limited domain begins with "*.", we nick off those characters and check it against the right side of the user's email domain. If a limited domain...
View Articlemilestone changed; keywords set
keywords needs-patch added milestone changed from Awaiting Review to Future Release Seems sensible. A patch would be great.
View Articlekeywords, component changed; focuses set
keywordscommit removedfocusesmultisite addedcomponent changed from Multisite to Login and Registration
View Articlemilestone changed
milestone changed from 3.7 to Future Release I started to break this down by removing is_email_address_allowed() all together, and using is_domain_in_list() directly in the validate signup function. I...
View ArticleArticle 47
I'm a fan of _whitelist and _blacklist. The change to is_domain_in_list() is appealing too.
View ArticleArticle 46
But I will note the option names are "limited" and "banned", not "allowed" and "unsafe". Ah right, I was misremembering. I guess I made up "allowed". The clearest terms to me are 'whitelist' and...
View ArticleArticle 45
I guess I don't quite see "allowed" and "unsafe" being parallel. Maybe I'm wrong? I guess "safe" would make more sense, but that's not good either because it isn't strictly an inverse. Maybe we go...
View ArticleArticle 44
What about is_domain_in_list() that is allowed to receive an email address? If @ exists, we explode on it, otherwise, we just assume the whole string is the email. I like that idea. See 15706.4.patch,...
View ArticleArticle 42
So I think the only objection I have to this is the function naming. is_email_domain_in_list() is okay, but not great. It receives a full email address, but its name suggests it is not just checking...
View Articlekeywords changed
keywordscommit added; dev-feedback removed I've asked westi to look this over.
View ArticleArticle 40
Patch works for me, tests come out as expected before and after patch, docs look good. I tweaked a little in 15706.3.diff to add @ticket annotations to the tests and remove one whitespace change that...
View Articlekeywords changed
keywordsneeds-docs removed15706.5.diff adds docs to the previous patch.
View ArticleArticle 33
15706.4.diff does a few things:Merges Boone's 2 patches into one for develop.svnAccounts for the changes in [25197] that added case insensitivity to the email checkRemoves unused local...
View Articlekeywords changed
keywordshas-patch added; needs-refresh removed 15706.3.patch is a refresh against trunk that does the following (some overlap with #21730):Introduces is_email_domain_in_list(), a utility function for...
View Article